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Chapter 1: Introduction 
Welcome to the Test Automation on Windows Mobile 5 Getting Started guide. This document will assist 

you with installing, configuring and using M-eux Test. To make sure you can get started automating your 

test cases as soon as possible, we invite you to closely follow the instructions contained in this guide.  

We have made every attempt possible in making the instructions in this guide as clear as possible. 

However, we recognize that we are unable to cover everything in a single guide. Should you require 

further assistance, please do not hesitate to visit our www.jamosolutions.com website or to contact our 

support team at support@jamosolutions.com. 

After reading his document, you should be familiar with the following topics: 

 Test automation on real Windows Mobile 5 devices 

 Test automation on Windows Mobile 5emulators 

 Best practices on Windows Mobile 5 testing 

1.1. M-eux Test overview 

To test mobile applications using M-eux Test, you need three main components. The Windows Mobile 5 

device or Windows Mobile 5 emulator hosts the application that you want to test. You use a scripting 

environment in which you write and execute your scripts. Finally, the M-eux Test Device Manager is the 

core of our application and acts as the gateway between the mobile devices and scripting environment. 

M-eux Test currently supports the following products: 

 Windows Mobile 5 Devices: Both Windows Mobile 5 emulators and real actual devices are 

supported. This connection can be established through USB via ActiveSync or Windows Mobile 

Device Center (Windows Vista), or the network connection of the device. 

 

Figure 1: M-eux Test Architecture 

http://www.jamosolutions.com/
mailto:support@jamosolutions.com
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1.2. How to use this document 

This document will get you started with using M-eux Test for testing applications on Windows Mobile 5. 

To get started, here’s what you need to do: 

- Get your PC ready. You will first need to install M-eux Test on your PC. 

- Get your device or emulator ready. Depending on your testing strategy, you may want to run 

your test on a physical device or an emulator. M-eux Test supports both.  

- Create your first script. Once your pc, device and app are ready, you can start creating your first 

script.  

1.3. Where to go from here 

This document will get you started creating your first script. If you want to further explore the features 

of M-eux Test, please visit our website at www.jamosolutions.com for further information on the 

features of M-eux Test.  

http://www.jamosolutions.com/
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Chapter 2: Get your PC ready 

2.1. System Requirements 

The supported systems and requirements: 

Computer/processor IBM-PC or compatible with a Pentium III or higher (Pentium IV or 
higher recommended) microprocessor. 

Operating System Windows Desktop 

 Windows XP 32-Bit Edition—Service Pack 3, 

 Windows Vista (32-bit edition & 64-bit Edition), 

 Windows 7 (32-bit Edition & 64-bit Edition) 

 Windows 8 (32-bit edition & 64-bit edition) 

 Windows 8.1 (32-bit edition & 64-bit edition) 
 
Windows Server 

 Windows Server 2003 32-bit Edition—Service Pack 1, 

 Windows Server 2003 R2 (32-bit x86), 

 Windows Server 2008 (32-bit & 64-bit edition) 

 Windows Server 2008 R2  

 Windows Server 2012  

 Windows Server 2012 R2 

Memory Minimum of 2 GB. 

Color Settings Minimum of High Color (16 bit). 

Free disk space 1 GB of free disk space for application files and folders and an 
additional 1 GB of free disk space on the system disk (the disk on 
which the operating system is installed). 
The free disk space requirements do not include disk space required 
for any prerequisites that may need to be installed before installing 
M-eux Test. 
After M-eux Test is installed, it is recommended to have at least 1 GB 
free disk space on the system disk for the operating system and M-
eux Test to run correctly. 

2.2. Prerequisites  

To install M-eux Test on your computer, you first need to install the following prerequisites: 

- Windows Mobile 5.0 Pocket-PC Emulator. This emulator is a part of Windows Mobile 5.0 SDK 

package. Full package can be downloaded from: http://www.microsoft.com/downloads   

- Device Emulator Manager. This application comes in package with Microsoft Visual Studio, 

otherwise downloadable at http://msdn.microsoft.com 

- Device Manager. More information on the Device Manager can be found in the manuals: ‘User’s 

Guide –QTP’ and ‘User’s Guide – Visual Studio’. 

http://www.microsoft.com/downloads
http://msdn.microsoft.com/
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- ActiveSync (Windows XP only). Downloadable at: 

http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-

download.mspx 

- Optionally, OCR components 

Once all prerequisites have been installed, you can continue with the installation of M-eux Test. You 

may be required to execute some post-configuration tasks to ensure M-eux Test will work correctly in 

your environment. 

2.2.1. Mobile Device Prerequisites 

In case of Windows Mobile devices and emulators, ActiveSync from Microsoft is needed in order to 

connect the PC to the mobile device for Windows XP and Windows 2003. Windows Vista and Windows 7 

require the Windows Mobile Device Center. 

In case of Android devices, the SDK of Android needs to be installed together with the USB drivers from 

Android in order to connect the mobile device with the PC using a USB cable. 

In case of BlackBerry devices, the “BlackBerry Desktop Software” needs to be installed. 

For iOS devices – you can download the latest iTunes from apple website. 

2.2.2. Required Privileges 

You need to have local system administration rights in order to install the product. 

2.2.3. Visual C++ 2010 Redistributable 

M-eux Test requires the Visual C++ 2010 Redistributable to be installed on your PC. You can download 

the Visual C++ 2010 Redistributable from http://www.microsoft.com/en-

us/download/details.aspx?id=8328 . 

2.2.4. .NET Framework 4.0 

M-eux Test requires version 4.0 of the .NET Framework to be installed on your PC. You can download 

the .NET Framework from http://www.microsoft.com/en-us/download/details.aspx?id=17718 . 

2.3. Installing M-eux Test  

In order to test applications on Android devices or Android emulators, you need to install the M-eux 

Device manager. As shown in the architecture, the device manager is used to communicate between the 

device and the test tools. 

You can download the set up on our website:  M-eux Test Setup at 

http://www.jamosolutions.com/memberArea/downloads.php. You will need to have a credential to log 

in the member area network. If you do not have the credentials yet, please email us at 

info@jamosolutions.com 

It is mandatory to install the application with admin rights, simply right click on the MeuxSetup.msi and 

run as admin rights. 

http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.mspx
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.mspx
http://www.microsoft.com/en-us/download/details.aspx?id=8328
http://www.microsoft.com/en-us/download/details.aspx?id=8328
http://www.microsoft.com/en-us/download/details.aspx?id=17718
http://www.jamosolutions.com/memberArea/downloads.php
mailto:info@jamosolutions.com
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2.3.1. Preparation 

1. First step is to execute the MeuxSetup.msi file from the M-eux build you downloaded on your PC. 

The dialog boxes will guide you through the installation. 

2. Click Next 

 

Figure 2 Installing M-eux Test 

3. Setup will check the components which are already installed on the pc and will indicate if any 

additional component is required. Review all warnings and errors and click Next to continue the 

installation process. 

 

Note: The Android SDK check will issue a warning if you have downloaded and copied the zipped 

version of the SDK. No warning will be displayed if you have used the installer to install the Android 

SDK. Please see the instructions here for more information. 

 

4. If you agree with the License Agreement, select I accept the terms in the License Agreement and 

click Next. 
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Figure 3 Accepting license 

5. Select: 
a.  Unified Functional Testing (QuickTest Professional) if you want to use M-eux Test with 

QTP/UFT.  
b. Select Visual Studio 2005 if you want to use M-eux Test with Visual Studio 2005 sp1.  
c. Select Visual Studio 2008 if you want to use M-eux Test with Visual Studio 2008 sp1.  
d. Select Visual Studio 2010 if you want to use M-eux Test with Visual Studio 2010.  
e. Select Visual Studio 2012 if you want to use M-eux Test with Visual Studio 2012.  
f. Select Visual Studio 2013 if you want to use M-eux Test with Visual Studio 2013.  
g. Select Execution M-eux Visual Studio scripts if you want to execute only Visual Studio based 

scripts on this PC.  
h. Select Eclipse Extension if you want to use M-eux Test with Eclipse 

Note: You cannot extend Visual studio 2008 and Visual studio 2005 at the same time. 

 

Figure 4 Choose Extensions 

6. If you have selected the Eclipse Extension then setup will ask you to point to the directory where 

Eclipse is installed. Please make sure you point to a 32-bit version of Eclipse. 
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7. Click on “Install” to start the actual installation. 

 
8. Wait until Setup is has completed. Depending on your environment, this may take up to 10 minutes 

as setup is preparing your PC for smooth automation. 
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2.4. License activation 

Start the device manager application on the PC. 

When starting the first time the device manager, you get the device manager without possibility to 

connect devices or tools. You have to install a license first. Depending on the purchased license(s), you 

can choose between seat, site and token license. 

Seat License activation 

In case of a seat license, select the menu Tools, License, New license, Seat. Write down the locking id 

and send this id to Jamo Solutions: support@jamosolutions.com. Jamo solutions will return the file with 

the license keys. A path name to this file needs to be entered in the edit field linked to the Seat License 

Details section. You can write the path manually or use the ‘Select button’ to find and select your license 

key file. 

 

Figure 5 Seat license activation 

After selecting “OK”, the file will be read and the seat license will be installed. 

mailto:support@jamosolutions.com
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Site license activation 

In case of a site license, select the menu Tools, License, New license, Site. Enter the IP or hostname and 

port of the license server.  The license server URL will be generated automatically. 

 

Figure 6 Site license activation 

Note that prior to connecting to the license server machine, the license server needs to be installed on 

that machine.  The licenses will be checked at run-time, so you need to be connected to the license 

server all the time while using the Device Manager. 

If you have problems connecting to the license server, then please contact your product administrator 

who is responsible for the M-eux license server. 

Note the site license will be released if you shut down your device manager. So if you want to transfer 

the site license to another tester in your company. You just need to shut down your Meux Device 

Manager. 

Token license activation 

Token licenses are distributed by your local license server. They allow you to use the tool while not 

being connected to the license server. 

In case of a token license, select the menu Tools, License, New license, Token. In the details enter the IP 

or hostname and port of the license server.  The license server URL will be generated automatically. 



M-eux Test: Windows Mobile 5 Getting Started Guide   

Page 14  

 

Figure 7 Token license activation 

Note that prior to connecting to the license server machine, the license server needs to be installed 

activated and running on that machine.  

 The checkbox Web Add-in consumes a web support for each tool demanded license. 

 The Token # days edit field contains the number of days that the token will be used by the 

machine, i.e. the number of days that the token will be valid. 

 The checkbox DM Professional denotes the license for the device manager professional edition. 

A license device manager professional activates the WAN Connector and local scheduler 

functionality. 

 The checkboxes Specific Platform and Platform All denote the platform of your connected 

devices. Only one of these checkboxes can be checked.  

 If you check Specific platform you have to select in the combo box under the platform you wish. 

If you select nothing, the Windows Mobile/CE platform will be levied. Selecting Windows 

Mobile/CE denotes that Mobile-based or Windows CE-based devices can connect to the Device 

Manager directly or indirectly through the WAN connector. Selecting Android denotes that 

android-based devices can connect to the Device Manager directly or indirectly through the 

WAN connector. 

 Checkbox Platform All denotes that any supported mobile device can connect to the Device 

Manager directly or indirectly through the WAN connector. 

 The other fields contain the number of token-licenses you want to have active for the specified 

time period indicating that all tokens have the same duration as specified in Token #days. 

Following table explains the tokens one can request: 
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Token Edit field Description 

Development Denotes the number of development tokens. With one development 
token, the QA engineer can create, modify and execute a script. Normally 
this number is one since most of the time the QA engineer is working on 
one script at a time. 

Execution Denotes the number of execution tokens. With one execution token, you 
can execute a script. With N execution tokens, you can execute N scripts 
simultaneously. 

Tool QTP (QuickTest 
Professional) 

Denotes the number of QuickTest Professional tokens. This number is 0 or 
one since you can run only one QuickTest Professional instance at a time. 

Tool ALL Denotes the number of tool instances you can launch simultaneously. 
Currently Quick Test Professional and QuickTest Professional are 
supported. 

 

After clicking OK, you will receive an overview of requested and received licenses. If all requested 

licenses are not granted, it means that they are in use by other users. 

 

Figure 8 Token license overview 

Note that for any license installation (install new license, switch to another license or release token 

license) all devices and tools have to be disconnected. 

Handling the token license 

All token licenses have an expiration date. If the you want to release these tokens before the expiration 

date, you can do it by calling the menu item Tools, License, Release Token License or by installing a new 

license (seat, site).  Before calling one of these menu items, you need to connect your machine to the 

network so that the license server is reachable. The menu item Release Token License will release all 

tokens and switch your license to site license connecting to the same license server address that was 

used to book and un-book the tokens. 
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Managing the professional license 

The Device Manager will at startup time look to book a Professional license. You can release this license 

and use the Device Manager in Standard mode by selecting Tools, Licenses, Release Device Manager 

Pro. Performing this action will disconnect all connected WAN connectors and disable the scheduler. 

If the Device Manager is in Standard mode, you can book a Professional license by selecting the menu 

Tools, Licenses, Get Device Manager Pro. 

You can verify the mode the Device Manager is in by inspecting the menu entry in Tools, Licenses. The 

menu entry Release Device Manager Pro indicates that the Device Manager is in Professional mode. The 

menu entry Get Device Manager Pro indicates that the Device Manager is in Standard mode.  

License overview 

 

Figure 9 License overview 

At each time you can check your available licenses in menu Tools, Licenses, License Overview. The 

displayed form shows the number of licenses in use and if using a seat or token license, the number of 

licenses available locally on your PC. 

2.5. Troubleshooting 

2.5.1. The device is not able to (re)connect to the M-eux device manager  

The communication between the PC and the mobile device is using the TCP/IP network protocol. A local 

firewall installed on the PC may block the communication between the PC and the mobile device. The 

TCP/IP protocol uses ports and IP addresses to establish communications. 
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We recommend you allow communication on the following IP-address blocks: 

- 169.254.*.* (autoconfiguration IP addresses) 

- 192.168.*.* (private IP range) 

- All other IP ranges that are used for establishing connections between the mobile device and 

the desktop (e.g. Wi-Fi, Bluetooth, …) 

And on the following ports: 

- 4444, 555, 5580-5590 

2.5.2. The device manager ports are already in use 

Since the communication between the Device Manager and the script (and vice versa) is using .Net 

Remoting technology, ports are needed for communication. The ports that are used by the M-eux Test 

tool can be modified in “MeuxDeviceManager.exe.config” (see the bin folder of the installation 

directory). 

After launching Device Manager or Wan Connector you get message(s) that a port is already used on 

this machine 

 

You have to go to the configuration file of Device Manager (Wan Connector) and change the specified 

port there. For details see the User guide, section Wan Connector configuration. 

 

1. Make sure your local firewall does not block the communication of the device manager, you can 

enable the communication by: Control panel—Firewall—Allowed programs and make sure you 

have device manager listed in there and it can communicate through firewall in both home and 

public network. 
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Figure 10 Allow the communication of Device Manager on firewall 

 

If the Device Manager program does not appear in the above window, you can click the button Allow 

another program in the above picture and point to MeuxDeviceManager.exe in the bin directory of the 

M-eux Test. 
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Chapter 3: Getting your device ready 
This section explains how to install the Agent on a real mobile device. 

3.1.1. Mobile Device Prerequisites 

You must have access to the registry of the device. 

You must have privilege access to the device in order to have full GUI object oriented support. 

Consult the following Microsoft article on the access rights to the mobile device:  

http://www.microsoft.com/technet/community/columns/secmvp/sv0107.mspx 

You must have at least a two-tier security model on your device.  If you do not have privilege access, you 

can use a certificate in order to grant you this access. Please consult your mobile operator or mobile 

manufacturer for more information regarding the available certificates. 

.Net Compact Framework 2.0 or higher must be installed on the device. 

3.1.2. Installation 

(All screenshots were made on an emulator) 

1. Connect your device to the PC. 

 

2. Copy “M-euxAgent_WM5_PPC.cab” file from the installation folder of our product (C:\Program 

Files\Jamo Solutions\M-eux Test\setup\Windows Mobile) into “Temp” folder on the Mobile 

Device. To access Temp folder on Windows Vista, go to “Computer”, double-click the name of 

your device, select the disk, then “Temp”. On Windows XP go to ActiveSync window and click 

“Explore” -> “My Windows Mobile-based Device” -> “Temp”  

 
 

http://www.microsoft.com/technet/community/columns/secmvp/sv0107.mspx
file:///C:/Program%20Files%20(x86)/Jamo%20Solutions/M-eux%20Test/setup/Windows%20Mobile
file:///C:/Program%20Files%20(x86)/Jamo%20Solutions/M-eux%20Test/setup/Windows%20Mobile
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3. On the device click “Start” -> “Programs” -> “File Explorer” -> “Temp”, you will see the 

previously copied file there. 

 

4. Click the “M-euxAgent_WM5_PPC.cab” file, installation process should begin immediately. 
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5. Once successful installation message is displayed, restart the device.  

 

6. You can now start the Agent by clicking “Start” -> “Programs” ->  “M-eux Agent”  
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7. At the following screen select “Serial USB” and press “Connect”  

        If option “Serial USB” is not available, make sure that the device is properly connected. 

 

 
 

 

The Agent is now ready for use.  
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Chapter 4: Getting your emulator ready 

4.1. Prerequisites 

Before installing the agent, make sure that following items are installed on your PC: 

 Windows Mobile 5.0 Pocket-PC Emulator. This emulator is a part of Windows Mobile 5.0 SDK 

package. Full package can be downloaded from: http://www.microsoft.com/downloads   

 Device Emulator Manager. This application comes in package with Microsoft Visual Studio, 

otherwise downloadable at http://msdn.microsoft.com 

 Device Manager. More information on the Device Manager can be found in the manuals: ‘User’s 

Guide –QTP’ and ‘User’s Guide – Visual Studio’. 

 ActiveSync (Windows XP only). Downloadable at: 

http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-

download.mspx  

4.2. Installation 

1. In the Device Emulator Manager right-click Windows Mobile 5.0 Pocket PC Emulator and select 

“Connect” 

 

2. After the emulator has loaded, once again right-click it in the list and select “Cradle”.  

 

http://www.microsoft.com/downloads
http://msdn.microsoft.com/
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.mspx
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.mspx
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3. Copy “M-euxAgent_WM5_PPC.cab” file from the installation folder of our product (C:\Program 

Files\Jamo Solutions\M-eux Test\setup\Windows Mobile) into “Temp” folder on the Emulator.  

 
 

To access Temp folder of your device on Windows Vista, go to “Computer”-> “Pocket_PC”, 

select the disk, then “Temp”.  

On Windows XP go to ActiveSync window and click “Explore” -> “My Windows Mobile-based 

Device” -> “Temp”  

 

If you cannot see “Temp” folder in the list, check “Show hidden files and folders” in “Tools”-

>”Folder Options”->”View” on your PC 

file:///C:/Program%20Files%20(x86)/Jamo%20Solutions/M-eux%20Test/setup/Windows%20Mobile
file:///C:/Program%20Files%20(x86)/Jamo%20Solutions/M-eux%20Test/setup/Windows%20Mobile
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4. On the Emulator click “Start” -> “Programs” -> “File Explorer” -> “Temp”, you will see the 

previously copied file there. 
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5. Click the “M-euxAgent_WM5_PPC.cab” file, installation process should begin immediately. 

 

 

 

6. Once successful installation message is displayed, do a soft reset of the Emulator. When 

prompted “Are you sure you want to reset the guest OS?” click “Yes”. 
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7. After restarting the Emulator needs to be re-cradled. In the Device Emulator Manager window, 

right-click the WM5 emulator and select “Uncradle”, then once again right-click it and select 

“Cradle”.  

 

 

8. You can now start the Agent by clicking “Start” -> “Programs” ->  “M-eux Agent”  
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9. At the following screen select “Serial USB” and press “Connect”  

        If option “Serial USB” is not available, make sure that the emulator is cradled. 

 

 

The Agent is now ready for use.  
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Chapter 5: Launching your application 
Tip: This procedure is only required for applications using the Microsoft .NET Compact Framework 

(CF). 

If the application you want to test is a .NET Compact Framework (CF) application, you need to enable 

our support for .NET CF applications. 

The .NET CF support can only be enabled if the application under test is launched by M-eux Test. There 

are two ways to launch the application under test: 

1. You can launch the app under test from the script with the command NetCFAppLaunch or 

one of its variants. 

2. You can redirect the executable and launch the app in the normal way (by the icon or the 

AppLaunch method from the script). 

Note that if you choose for option 1, the application cannot be started prior to the execution of 

NetCFAppLaunch in the script. If your application starts up automatically while booting the device, 

option 2 must be used. 

5.1. NetCFAppLaunch Method 

The NetCFAppLaunch has many variants. You need to know whether: 

- Your app runs on .NetCF version 2 or version 3.5, and   

- Wheter your app is using Resco Components and if so, the version of Resco. 

The variants are: 

METHOD USAGE M-EUX CALLING EXECUTABLE 

NETCFAPPLAUNCH Use this command for 
.NetCF version 2.0 
applications. 

ManagedWrapper.exe 

NETCFAPPLAUNCH35 Use this command for 
.NetCF version 3.5 
applications. 

ManagedWrapper35.exe 

NETCFRESCOAPPLAUNCH Use this command for 
.NetCF version 2.0 
applications using Resco 
6.11 

RescoManagedWrapper.exe 

NETCFRESCOAPPLAUNCH35 Use this command for 
.NetCF version 3.5 
applications using Resco 
6.11 

RescoManagedWrapper35.exe 

NETCFRESCO612APPLAUNCH Use this command for 
.NetCF version 2.0 

Resco612ManagedWrapper.exe 
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applications using Resco 
6.12 

NETCFRESCO612APPLAUNCH35 Use this command for 
.NetCF version 3.5 
applications using Resco 
6.12 

Resco612ManagedWrapper35.exe 

NETCFRESCO2005APPLAUNCH Use this command for 
.NetCF version 2.0 
applications using Resco 
2005 

Resco2005ManagedWrapper.exe 

The commands have 3 parameters: 

• Parameter 1: the name of your executable. 

• Parameter 2: the full path to the directory where your executable is located. 

• Parameter 3: command line arguments of the application. In most cases, no arguments are 

passed and you specify the empty string “”. 

If you execute the command, following actions take place: 

• The tool copies the corresponding managedwrapper.exe from the C:\Windows directory to 

the directory specified as the second parameter 2. 

• The managedwrapper.exe process will start up the specified application ( parameter 1) 

inside its process 

Doing so enabled our support. 

This option cannot be applied in following cases: 

• The application is started up at boot time of the system. Either you stop/kill the application 

manually before executing the NetCFAppLaunch command or you apply option 2. 

• The application is consulting the name of its process to access for example files. The name 

of the process is normally the name of the executable. By using the NetCFAppLaunch 

command, the process name is ManagedWrapper.exe. You have to use option 2 in this case. 

5.2. Redirect Method 

On windows mobile/CE an application is started up by its executable. An icon or automatic startup 

during boot refers to this executable. 

In this solution, we make that an executable of M-eux test replaces the executable of the application 

under test. The procedure is as follows: 

1. Rename the executable of the application under test: example: your executable name is 

myapp.exe. Rename it to a new name, for example: myappOrig.exe 

2. Copy the corresponding managedwrapper.exe to the directory of your executable (see table 

in option 1).  

3. Rename our executable to your name. In the example rename it to myapp.exe 
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4. Put a file in the directory with name: myapp.exe.redirect. This file is a XML file with 

following content: 
<managedWrapper> 

 <program>myappOrig.exe</program> 

</managedWrapper> 

What happens when applying this redirect setup? Here is the explanation using the example data: 

When clicking on the icon or when rebooting, the system will call myapp.exe. This is the M-eux 

application previously named managedwrapper.exe. This application will look for the 

myapp.exe.redirect file. Open it, read out the program name and startup myappOrig.exe 

With other words, the application under test is called by the M-eux test application 

managedwrapper.exe 
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Chapter 6: Your first script 
M-eux Test extends three well known environments to create your scripts: Quick Test Professional from 

Hewlett Packard and Quick Test Professional from Microsoft and Eclipse. Detailed information on both 

environments can be found in the guide: ‘User’s Guide – QTP’ or ‘User’s Guide Quick Test Professional’ 

or ‘User’s Guide - Eclipse ’.  

The following section explains the creation of the first script in QuickTest Professional. The section after 

that explains creation of the script in Visual Studio, and Eclipse is explained last.  

6.1. Creating the first script in QuickTest Professional. 

This section explains how to create your first script in QuickTest Professional. The test case will navigate 

through the file system of the device using mobile version of the File Explorer program. The recorded 

commands, as shown in QTP in the expert view, are mentioned in each step. Any command in the expert 

view of the script must be specified on one line! In this document, a command might be printed over 

several lines if the length of the command exceeds the width of the page. 

1. Before creating the script, open the root directory of the file system in File Explorer. You can do 

that by clicking “Start” -> “Programs” -> “File Explorer”. 

 

 
2. Start recording the script by pressing “Record” in QTP window.  
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The next steps will be recorded in QTP until the recording is stopped. 

3. Click “My Documents” 

 

 

 Following statement is recorded: 

MobileDevice("Pocket_PC").MoWindow("File 

Explorer").MoObject("ATL:01F65650").MoListCtrl("SysListView32").Select "My Documents" 

The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons. 

4. Click “My Music” 
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Following statement is recorded: 

MobileDevice("Pocket_PC").MoWindow("File 

Explorer").MoObject("ATL:01F65650").MoListCtrl("SysListView32_2").Select "My Music" 

The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons. 

5. Click “My Music” on the toolbar in top left corner to summon a drop-down menu. 
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Following statement is recorded: 

MobileDevice("Pocket_PC").MoWindow("File Explorer").MoToolBar("ToolbarWindow32").Select "#0" 

6. Click “My Device” in the menu. 

 

 
  

Following statement is recorded: 

MobileDevice("Pocket_PC").MoWindow("File Explorer").MoMenu("MNU").Select "My Device" 

7. Click “Stop” in QTP window to stop recording. 

Click “Run” to execute the script. 

 

 
 

 

Following image shows the recorded script in Expert View: 
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8. In order to complete the test case, the file explorer program needs to be started automatically 

from the script. It is a pre-condition that the file explorer is running and showing the root 

directory. Insert this line in the beginning of the script, above the existing lines:  

MobileDevice("Pocket_PC").AppLaunch "fexplore", "\", "" 

This command will make the device open File Explorer in the root directory. 

In order for the script to function properly, correct name of the device should be used instead of 

“Pocket_PC”, hence you cannot copy-paste any command from this document. It is necessary to type 

this and all the following commands manually. QTP will automatically insert the correct name when 

you type MobileDevice( 

 

   

9. Insert the next line under the one we added in the previous step: 

itemCount = MobileDevice("Pocket_PC").MoWindow("File 

Explorer").MoObject("ATL:01F65650").MoListCtrl("SysListView32").GetItemCount() 

The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons. 

This command will count the number of items in the root directory of File Explorer and store the 

value in the itemCount variable. 

10. Finally, add the following line to the end of the script in order to compare the current number of 

items in the root directory with the value when the file explorer was first opened. This expected 

value was previously stored in the itemCount variable: 

MobileDevice("Pocket_PC").MoWindow("File 

Explorer").MoObject("ATL:01F65650").MoListCtrl("SysListView32").CheckProperty "itemCount", 

itemCount  

The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons. 

Now the script is finished and should look like this: 
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11. Press “Run” in QTP.  Once the script execution is finished, you will receive Test Results, where 

you can see the result of CheckProperty function.  

 

 

6.2. Creating the first script in Microsoft Visual Studio 

This section explains how to create your first script in Microsoft Visual Studio. The test case will navigate 

through the file system of the device using mobile version of the File Explorer program. The recorded 

commands are mentioned in each step. Any command in the script must be specified on one line! In this 

document, a command might be printed over several lines if the length of the command exceeds the 

width of the page. 

The following script was made on an emulator. If made on a real device, another name for the device 

will be recorded in the script. 

1. In Visual Studio click “File” -> “New” -> “Project…”.  
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2. In the next window select “Visual C#” in the Project type’s column on the left and “M-eux 

Test - Script” under My Templates on the right. Type in a name for your script and press 

“OK”. 

 
3. In the following window press “OK”.  
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4. Open the “Add-in manager” dialog box from the “Tools Menu”. 

 

 
 

5. Select the “M-eux VS Addin” option 

 

 
 

6. The “M-eux Test Menu” will be added in Visual Studio 
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7. Select “Connect” from the “M-eux Test Menu” to connect Visual Studio to the device 

manager. The “Visual Studio Addin” will be listed in “Connected Testing Tools”. 

 

 
 

8. Before creating the script, open the root directory of the file system in File Explorer on your 

emulator or device. You can do that by clicking “Start” -> “Programs” -> “File Explorer”. 

 
9. Select “Start Recording” from the “M-eux Test Menu”. 
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10. Place the cursor after “// Have Fun” in the script. 

 

 

The next steps will be recorded in Visual Studio until the recording is stopped. 

11. Click “My Documents” on the device 
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Following statement is recorded: 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.Select("My Documents"); 

 

12. Click “My Music” 

 

   

Following statement is recorded: 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32_2.Select("My Music"); 

13. Click “My Music” on the toolbar in top left corner to summon a drop-down menu. 
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Following statement is recorded: 

pocket_PC.file_Explorer.toolbarWindow32.Select("#0"); 

14. Click “My Device” in the menu. 

 

 
  

Following statement is recorded: 
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pocket_PC.file_Explorer.mNU.Select("My Device"); 

15. Now select “Stop Recording” from the “M-eux Test Menu” 

 

 
 

Following image shows the recorded script: 

 

 

16. In order to complete the test case, the file explorer program needs to be started 

automatically from the script. It is a pre-condition that the file explorer is running and 

showing the root directory. Insert this line in the beginning of the script, under “// Have 

Fun”:  

pocket_PC.AppLaunch("fexplore", "\\", ""); 

This command will make the device open File Explorer in the root directory. 

In order for the script to function properly, correct name of the device should be used instead of 

“pocket_PC”, hence you cannot copy-paste any command from this document. It is necessary to type 

this and all the following commands manually.  

17. Insert the next line under the one we added in the previous step: 

String itemCount = 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.GetItemCount(); 

The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons. 
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This command will count the number of items in the root directory of File Explorer and store the 

value in the itemCount variable. 

 

18. Finally, add the following line to the end of the script in order to compare the current 

number of items in the root directory with the value when the file explorer was first 

opened. This expected value was previously stored in the itemCount variable: 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.CheckProperty("itemCount", 

itemCount); 

The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons. 

 

Now the script is finished and should look like this: 

 

 

19. Press “Start Debugging” to run the script.   
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Once the script execution is finished, you will receive Test Results, where you can see the result of 

CheckProperty function.  

 

6.3. Creating the first script in Eclipse 

This section explains how to create your first script in Eclipse. The test case will navigate through the file 

system of the device using mobile version of the File Explorer program. The recorded commands are 

mentioned in each step. Any command in the script must be specified on one line! In this document, a 

command might be printed over several lines if the length of the command exceeds the width of the 

page.  

1. In Eclipse click “File” -> “New” -> “Other…” 
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2. In the following window select “Jamo Solutions” -> “M-eux Test” 
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3. Specify project name and desired location 

 

 
4. Press “Connect” button on the toolbar to connect Eclipse to Device Manager. The “Eclipse 

Addin” will be listed in “Connected Testing Tools” in Device Manager. 

 

 
 

 

5. Before creating the script, open the root directory of the file system in File Explorer on your 

emulator or device. You can do that by clicking “Start” -> “Programs” -> “File Explorer”. 
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6. Press “Start Recording” button on the toolbar. 

 

 

Following steps will be recorded in the body of the runCore function of UserScript.java in Eclipse 

until the recording is stopped.  Statements will always be added at the end of the script. 

7. Click “My Documents” on the device 
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Following statement is recorded: 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.select("My Documents"); 

 

8. Click “My Music” 

 

Following statement is recorded: 

 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.select("My Music");  
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9. Click “My Music” on the toolbar in top left corner to summon a drop-down menu. 

 

Following statement is recorded: 

 
pocket_PC.file_Explorer.toolbarWindow32.select("#0"); 

 

10. Click “My Device” in the menu. 

 

Following statement is recorded: 
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pocket_PC.file_Explorer.mNU.select("My Device"); 

 

11. Press “Stop Recording” button on the toolbar 

 

Following image shows the recorded script: 

 

 
 

 

12. In order to complete the test case, the file explorer program needs to be started automatically 

from the script. It is a pre-condition that the file explorer is running and showing the root 

directory. Under this line:  
public void runCore() throws MeuxException { 

 

insert the following line: 

pocket_PC.appLaunch("fexplore", "\\", ""); 

This command will make the device open File Explorer in root directory. 

 

In order for the script to function properly, correct name of the device should be used instead of 

“pocket_PC”, hence you cannot copy-paste any command from this document. It is necessary to type 

all the commands manually. 

 

 

13. Insert the next line under the one we added in the previous step: 

 

String itemCount = 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.getItemCount(); 
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The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons.  

 This command will count the number of items in the root directory of File Explorer and store the 

value in the itemCount variable. 

 

14. Finally, add the following line to the end of the script in order to compare the current number of 

items in the root directory with the value when the file explorer was first opened. This expected 

value was previously stored in the itemCount variable: 

 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.checkProperty("itemCount", 

itemCount); 

The above statement should be entered on one line. In this document it is split in several lines due to 

formatting reasons. 

 

Now the script is finished and should look like this: 

pocket_PC.appLaunch("fexplore", "\\", ""); 

String itemCount = pocket_PC.file_Explorer.aTL_01F65650.sysListView32.getItemCount(); 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.select("My Documents"); 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.select("My Music"); 

pocket_PC.file_Explorer.toolbarWindow32.select("#0"); 

pocket_PC.file_Explorer.mNU.select("My Device"); 

pocket_PC.file_Explorer.aTL_01F65650.sysListView32.checkProperty("itemCount", itemCount); 

 

15. To run the script click on the arrow next to the Run button and select “Run Configurations…” 

 

Then click “Search...” next to the Main class box 
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In the following window select “Runner – com.jamosolutions” 

 

Press “Apply” and after that “Run” 

 

 

After the initial run has been complete, you may run the script simply by pressing the Run button 

on the toolbar. 

 

You can access the result via Project Explorer on the left. You may need to refresh Project Explorer 

to be able to see the result. 
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Chapter 7: Summary 
Now you should be able to start with the testing on Windows Mobile 5.  

We wish you a good journey with your test adventure using M-eux Test tool. If you are facing any issues 

with our tool, or having trouble about making your test scripts for your test cases, you can always 

contact us at support@jamosolutions.com.  

mailto:support@jamosolutions.com

